SGI Techpubs Library

IRIX 6.5  »  Books  »  End-User  »  
IRIX NetWorker User's Guide
(document number: 007-2304-003 / published: 1997-01-11)    table of contents  |  additional info  |  download
find in page

Chapter 4. Backing Up and Recovering Files

This chapter describes the NetWorker Backup and NetWorker Recover windows.  It includes the backup and recover functions unique to each window.

For information on using functions common to both windows, see Chapter 3, “Browsing Filesystems.”  For a quick tour of the backup and recover programs, see Chapter 2, “Getting Started.”  If your site has the optional NetWorker Archive Application, be sure to read Chapter 5, “Archiving and Retrieving Files.”

Backing Up Files

This section assumes that you already know how to mark files for a backup.  For detailed instructions on viewing directories, marking and unmarking files, searching for files, or viewing file details, see Chapter 3, “Browsing Filesystems.”

If you are already familiar with the NetWorker Backup window, see the shortcut instructions on page 39.

Changing the NetWorker Server

NetWorker backs up your data according to a backup schedule determined by your system administrator.  Usually, a single NetWorker server backs up all the systems on a network.  You may need to change servers if your NetWorker server is down or you are experiencing network difficulties.

If you have more than one NetWorker server available on the network, you may have a choice of servers for backups.  In order to switch to a different NetWorker server, your system must be listed as a client of that server.  Check with your system administrator before you switch to a server other than the one that normally backs up your system.

To change NetWorker servers:

  1. Click the Change Server speedbar button, or choose Server from the Change menu in the NetWorker Backup window, as shown in Figure 4-1.

    Figure 4-1. Change Server Button and Menu

    Figure 4-1 Change Server Button and Menu

    The Change Server dialog box appears, as shown in Figure 4-2.

    Figure 4-2. Change Server Dialog Box

    Figure 4-2 Change Server Dialog Box

  2. Enter the hostname of the server in the Server field or click a name in the list of servers displayed.

    If you do not see the hostname of the server you need, click the Update Server List button to update the list of NetWorker servers available on your network.


    Caution: When you click the Update Server List button, NetWorker searches for every server available to your machine.  If you have a large network, this search could take awhile.


  3. Double-click the hostname to choose the new server or click Ok to choose the server shown in the Server field.


    Note: If you choose a NetWorker server that does not have your system listed as a client, you receive a notice similar to that shown in Figure 4-3.  If this occurs, locate another server, or contact your system administrator.

    Figure 4-3. Notice for Client Not Registered

    Figure 4-3 Notice for Client Not Registered

Starting a Backup

Use the Start speedbar button to start a backup on marked files or choose Start Backup from the File menu, as shown in Figure 4-4.

Figure 4-4. Start Backup Menu and Button

Figure 4-4 Start Backup Menu and Button

To start a backup:

  1. Mark the files you want to back up.

  2. Choose the NetWorker server (if necessary).

  3. Click the Start speedbar button.

    The Backup Options dialog box appears, with choices for the options NetWorker applies to your backup.

Choosing the Backup Options

NetWorker displays the Backup Options dialog box before starting the backup.  This gives you the opportunity to compress files and exclude patterns before the backup starts.  Compressing data reduces network traffic and saves space on the backup media.  Excluding patterns is convenient for specifying data you do not want to back up at all.

Compressing Files

To choose whether to compress the files you back up, select a choice for Do you want to compress this backup? in the Backup Options dialog box.  Notice that Yes is already highlighted as the default selection, as shown in Figure 4-5.

Figure 4-5. Backup Optione Dialog Box

Figure 4-5 Backup Optione Dialog Box

If you want NetWorker to compress your files during backup, you do not have to make a selection for the compression option, since Yes is the default selection.

If you back up to a device that compresses data, do not use the NetWorker file compression feature.  Click No to continue the backup without file compression.


Tip: Compressing data during backup saves space on the backup media and reduces network traffic, but may slow down the backup operation.  Check with your system administrator to find out if you should compress backup data.

Notice that No is highlighted as the default selection for the Do you want to exclude any patterns from this backup? choice.  If you do not want to exclude patterns of filenames from the backup, click Ok to continue the backup.

Excluding Patterns

You can exclude files from a backup using the Pattern options provided in the Backup Options dialog box.  This feature is useful, for example, if you are backing up an entire directory and do not need to back up certain files or subdirectories in that directory.  Excluding files from the backup also reduces network traffic and saves space on backup media.

To exclude files from the backup, specify alphanumeric patterns that occur in the names of the files you want to exclude.  Use UNIX shell pattern-matching characters to specify any number of patterns you want to exclude. To exclude patterns from the backup:

  1. Click Yes for the Do you want to exclude any patterns from this backup? choice.  This activates the lower half of the Backup Options dialog box.

  2. Enter the first pattern in the Pattern field.

  3. Click Add to add the pattern to the list.  The pattern appears in the pattern list display, as shown in Figure 4-6.

    Figure 4-6. Backup Options, Excluding Patterns

    Figure 4-6 Backup Options, Excluding Patterns

    If you want to change a pattern, select it in the pattern list.  The selected pattern appears in the Pattern field.  Enter the new pattern and click Change.  The new pattern replaces the old pattern in the pattern list.

    If you want to delete a pattern, select it in the pattern list and click Delete.

  4. Enter any remaining patterns and add them to the pattern list.

  5. Click Ok to continue the backup with the excluded file patterns and the compression choice.

Monitoring the Backup Status

The Backup Status dialog box appears after you complete your selections in the Backup Options dialog box and click Ok.  Use the Backup Status window to monitor the backup process.

Figure 4-7. Backup Status Window

Figure 4-7 Backup Status Window

The Backup Status dialog box provides the backup start time and the backup completion time.  The names of the files and directories scroll across the Backup Status dialog box as the backup proceeds.

The message at the bottom of the dialog box gives you information about the backup, including the full pathname of the directory, the amount of data, the amount of time it took, and the number of files saved.

If you do not see any progress messages in the Backup Status dialog box after a few minutes, the NetWorker server probably needs attention from the system administrator.  Click the Cancel button to cancel the backup.

A message similar to the following appears in the Backup Status dialog box when the backup completes:

Backup completion time: Fri Nov 3 14:20:42 1995

Click the Cancel button to close the Backup Status dialog box.

Backup Shortcut

Read this section if you are already familiar with the NetWorker Backup window.

To back up your directories or files:

  1. Click the nwbackup icon to open the NetWorker Backup window.

  2. Click the checkboxes, or highlight the directory or file you want to back up, and click the Mark speedbar button.

  3. Click the Start speedbar button.

  4. Click the Ok button in the Backup Options dialog box.

  5. Click the Cancel button in the Backup Status dialog box to close it after you check the backup completion message to make sure the backup is finished.

Recovering Files

This section assumes that you have already marked recovery files in the NetWorker Recover window.  For detailed instructions on viewing directories, marking files, searching for files, or viewing file details, see Chapter 3, “Browsing Filesystems.”  If you are already familiar with the NetWorker Recover window, see the shortcut instructions on page 53.

NetWorker displays entries in the NetWorker Recover window for the files it saved during a backup.  Select the files you want to recover from this list of entries.  NetWorker recover functions allow you to browse the index for previous backups, select various versions of the file to recover, view your marked files, relocate files upon recovery, and recover files from another authorized system.


Note: An authorized system is a client for which you have permission to recover data.


Starting a Recover

Use the Start speedbar button to start a recover on marked files or choose Start Recover from the File menu, as shown in Figure 4-8.

Figure 4-8. Start Recover Menu and Button

Figure 4-8 Start Recover Menu and Button

Before starting a recover, read the following sections explaining the treatment of naming conflicts during NetWorker recovery:

Choosing the Recover Server

Normally you recover files from the NetWorker backup server designated by your system administrator.  If you changed backup servers in the NetWorker Backup window, you must select the same server in the NetWorker Recover window to recover files backed up to that server. xx


Caution: The Change Server dialog box lists all the NetWorker servers on the network.  You can back up and recover files only from a server that lists your system as a client.

To choose a recover server in the NetWorker Recover window:

  1. Click the Change Server speedbar button, or choose Server from the Change menu.

    The Change Server dialog box appears, as shown in Figure 4-9.

    Figure 4-9. Change Server Dialog Box, Updated

    Figure 4-9 Change Server Dialog Box, Updated

  2. Click the Update Server List button to update the list of NetWorker servers on the network, if needed.  Double-click the server name to choose the server that has the files you need to recover.  The Server field changes to reflect the current selection. 

  3. Click the Ok button after you select a server.

    NetWorker updates the directory and file displays in the NetWorker Recover window.


    Note: Select the recover server you want before marking the files to recover.


Choosing the Recover Client

If you need to recover files for a client other than the system currently in use, choose Change Client from the Change menu.  The Change Client command opens a dialog box that lists all of the clients for the currently selected NetWorker server.  Check with your system administrator if you want to recover files other than your own.  You may not be authorized to recover files for other client systems. 

To choose a recover client:

  1. Choose Client from the Change menu in the NetWorker Recover window.

    The Change Client dialog box appears, as shown in Figure 4-10.

    Figure 4-10. Change Client Dialog Box

    Figure 4-10 Change Client Dialog Box

  2. Click the Update Client List button to update the list of NetWorker clients available on the selected server.

  3. Choose a client for which you are authorized to recover files.  The Client field changes to reflect the current selection.

  4. Click the Ok button after you select a client.

Selecting File Versions

The View pulldown menu in the NetWorker Recover window contains two choices not found in the NetWorker Backup window:  Versions and Volumes.  Information about the Volumes choice is in “Listing the Backup Volumes for a Recover”.

The Versions dialog box lists all the versions of a file or directory that have been backed up by the NetWorker server.  The dialog box also lists the backup volumes on which the files reside.  Use the Versions choice to view the backup history of a file and to mark a particular version of a file for recovery.


Caution: NetWorker displays versions of backed-up files and directories in the Versions dialog box.  You can only mark files for recovery in the Versions dialog box.  If you attempt to mark a directory in the Versions dialog box, you receive a warning similar to that shown in Figure 4-11.

Figure 4-11. Marking Directories in Versions Window

Figure 4-11 Marking Directories in Versions Window

In addition to providing the backup time and location of all backed-up versions of the selected file, the Versions dialog box provides the following information:  number of blocks, mode, permissions, number of links, owner, group, size in bytes, and last modified time.  The filename, including the complete path, is displayed at the top of the dialog box.  To identify different versions of a file, compare the Backup time indicated for each version.

The Location field includes the name of the backup volume and the device where the volume is mounted or the location of the backup volume (for example, offsite storage).  If no device is listed, it means that the backup volume must be mounted before you can recover the file.

To view the backup history of a file or directory in the NetWorker Recover window:

  1. Click a file or directory in the file display.

  2. Choose Versions from the View menu, shown in Figure 4-12.

    Figure 4-12. View Versions Menu

    Figure 4-12 View Versions Menu

    NetWorker retrieves several versions of the highlighted file or directory from the index and lists them by backup time, beginning with the most recent (as shown in Figure 4-13).  Use the scrollbars to view the complete backup history.

    Figure 4-13. Versions Window Showing Backups

    Figure 4-13 Versions Window Showing Backups

  3. Click More to retrieve additional versions from the index.  The More button becomes inactive after all versions are retrieved.

To mark a version of a file for recovery:

  1. Click the checkbox of the file version you want to recover.

  2. Click Ok to place the marked versions in the file display.


    Tip: When you mark a past version of a file in the Versions dialog box, it appears in the NetWorker Recover window file display with the same name as the most recent version.  Choose File Details from the View menu to display backup times and distinguish the multiple file versions displayed.


Changing the Browse Time

The Browse Time field, shown on the bottom right of Figure 4-14, displays the date and time you started the current NetWorker recover program session.

Figure 4-14. Browse Time in NetWorker Window

Figure 4-14 Browse Time in NetWorker Window

The NetWorker Recover window displays the index entries for files backed up at the time shown in the Browse Time field.  Choose Browse Time from the Change menu to modify the browse time displayed to another date.  Changing the browse time displays the entries for files backed up immediately before the new browse time.


Note: If there are no entries for files backed up for the selected time in the Browse Time field, NetWorker displays files that were backed up closest to that time, but not immediately after.  For example, if you change Browse Time to 10 a.m. on May 15, and the backup took place at 11 a.m. on May 15, NetWorker will not display the entries for the files backed up at 11 a.m.

Changing the browse time lets you view past versions of your files.  This is useful if you do not remember the name or location of the files you want to recover, but do remember they existed at some time in the past.  The Browse Time choice in the Change menu also helps you find deleted files that no longer appear in the Versions dialog box.  You can recover deleted files by changing the browse time to locate past versions of the files in the index.


Note: Use the Browse Time choice to browse and mark past versions of directories.  Marking a directory causes all its nested files and subdirectories to be marked.

To change the browse time to recover a past version of a file:

  1. Choose Browse Time from the Change menu in the NetWorker Recover window, shown in Figure 4-15.

    Figure 4-15. Change Browse Time Menu

    Figure 4-15 Change Browse Time Menu

    The Change Browse Time dialog box appears, as shown in Figure 4-16.

    Figure 4-16. Change Browse Time Dialog Box

    Figure 4-16 Change Browse Time Dialog Box

    The Previous, Today, and Next buttons control the month displayed.  After choosing a month, click a day in the calendar to select the browse time.


    Note: You can also change the browse time by entering a valid date and time in the Browse Time field and pressing [Enter] or clicking Ok.  The following formats are valid browse time entries:


    • last Friday, next Friday, third Friday

    • now (the current date and time)

    • + or – 3 seconds, minutes, hours, weeks, months, or years

    • hh:mm:ss (24 hour clock) or
      hh:mm:ss (am or pm) mm/dd/(yy) or
      month dd (yy)

  2. Click Ok after choosing a browse time.  The Browse Time field in the NetWorker Recover window changes to reflect the new browse time.  The file display and directory display of the NetWorker Recover window show files that were backed up at or before that time.  You may now mark past versions of files for recovery.


    Note: Any files or directories you marked for recovery before changing the browse time remain marked.


Showing Marked Files

List the files you marked for recovery by choosing Show Marked from the Mark menu.  This command is available only in the NetWorker Recover window.  Use the Show Marked command to review files marked for recovery before starting the recover operation.

To show the files marked for recovery:

  1. Choose Show Marked from the Mark menu of the NetWorker Recover window, as shown in Figure 4-17.

    Figure 4-17. Show Marked Menu Choice

    Figure 4-17 Show Marked Menu Choice

    The Files Marked for Recovery window appears, listing the pathnames and backup time of all marked files, as shown in Figure 4-18.

    Figure 4-18. Files Marked for Recovery Window

    Figure 4-18 Files Marked for Recovery Window

  2. Click Cancel to close the window.


    Tip: The Files Marked for Recovery window lets you verify that all the files you need to recover are marked before starting the recover.


Listing the Backup Volumes for a Recover

After you mark your files for a recover, you can find out if the backup volumes NetWorker needs are available.  If NetWorker cannot access the backup volume containing your file, it sends a message to the system administrator to load the volume.  This request could take some time to fulfill.  You may want to delay the start of the recover until the volume is available.

Choose Volumes from the View menu, as shown in Figure 4-19, to determine if the backup volume needed to recover a file is available.

Figure 4-19. View Volumes Menu Choice

Figure 4-19 View Volumes Menu Choice

To determine if the file you want to recover is immediately available for recovery:

  1. Mark the files or directories you want to recover in the NetWorker Recover window.

  2. Choose Volumes from the View menu.

    NetWorker displays a new window, similar to that shown in Figure 4-20.

    Figure 4-20. Recover Volumes Required Window

    Figure 4-20 Recover Volumes Required Window

    If the backup volume is available, which means the volume is mounted or in an autochanger, “all on-line” message appears in the Recover Volumes Required window.  The window displays the name(s) of the backup volume(s) and, if applicable, their location.  In the example shown in Figure 4-20, the volume midas.apr96.003 is offline, the volume midas.apr96.005 is in the DLT library, and the volume midas.apr96.008 is in the drive named /dev/rmt/tps6d6nrnsv.

Relocating Files

To recover files to a directory other than the one they were backed up from, use the Relocate menu item before you start the recover.  The Relocate operation creates a directory, if it does not already exist, and recovers your file to the new location.

To relocate recovered files into a new or existing directory:

  1. Choose Relocate from the Options menu in the NetWorker Recover window, shown by Figure 4-21.

    Figure 4-21. Options Relocate Menu Choice

    Figure 4-21 Options Relocate Menu Choice

  2. Enter the complete pathname of a directory where you want to place the recovered files into the Relocate to field, as shown in Figure 4-22.

    Figure 4-22. Relocate Window

    Figure 4-22 Relocate Window

  3. Click Ok to relocate the files into the new directory.

Renaming or Overwriting Recovered Files

When you start a recover, NetWorker displays the Conflict Resolution dialog box.  You must decide whether to rename recovered files or overwrite existing files when a naming conflict occurs.  A naming conflict occurs when a file you are recovering already exists or has the same name as a file in the current directory.  NetWorker will not overwrite existing files unless requested to do so.

The Conflict Resolution dialog box has two sections requiring a selection for resolving naming conflicts, as shown in Figure 4-23.

Figure 4-23. Conflict Resolution Dialog Box

Figure 4-23 Conflict Resolution Dialog Box

  1. Choose a response for the Do you want to be prompted when conflict occurs? question.  The default choice, Yes, is already highlighted.

    Clicking No allows you to resolve conflicts for the entire recover session without being prompted about individual files.  If you choose No, you must also choose a response for the When conflict occurs, NetWorker should? question.

    Clicking Yes allows you to resolve conflicts on for each file.  NetWorker prompts for instructions in the Filename Conflict dialog box every time it encounters a naming conflict.  Each time this occurs, select a choice for the Do you want to? question in the Filename Conflict dialog box, as shown in Figure 4-24, then click the Ok button.

    Figure 4-24. Filename Conflict Resolution Dialog Box

    Figure 4-24 Filename Conflict Resolution Dialog Box

    The following are choices for conflict resolution:

    Rename the recover file—NetWorker renames the recover file with a .R extension.  If a .R file exists, NetWorker adds another .R extension to the recover filename.

    Discard the recover file—NetWorker discards the recover file.  The existing file remains where it was.

    Overwrite the existing file – NetWorker replaces the existing file with the recovered file.  The existing file is lost and the recovered file becomes current.

  2. Click Ok to continue the recover after completing the Conflict Resolution dialog box or click Cancel to return to the NetWorker Recover window.

Monitoring the Recover Status

After the Conflict Resolution dialog box closes, the Recover Status window re-appears, as shown in Figure 4-25, and the recover continues.

Figure 4-25. Recover Status Window (Relocate)

Figure 4-25 Recover Status Window (Relocate)

The Recover Status dialog box provides you with the following information about your recover session:

  • The number of files to be recovered and where they will be relocated.  If you specified a directory in the Relocate dialog box, it is listed:

    Recovering 6 files within
    /usr/people/tut/books/2000/007-2304-003/online/ into
    /usr/people/tut/Reports
    

  • The estimated disk space required for the recover:

    Total estimated disk space needed for recover is 53 KB.
    

  • The name of the required backup volume and its location:

    Volumes needed (all on-line):
        midas.apr96.008 at /dev/rmt/tps6d6nrnsv
    

  • The number and names of files or directories being recovered:

    Requesting 6 files, this may take a while...
    

  • The new filenames, if you chose to rename recovered files, and a summary:

    Received 6 files from NSR server `midas'
    Recover completion time: Fri Apr 19 17:29:45 PDT 1996
    

To cancel the recover or to close the Recover Status dialog box, click the Cancel button.  When the recover completes, a message showing the recover completion time appears in the Recover Status dialog box.

Recover Shortcut

Read this section if you are already familiar with the NetWorker Recover window.

To recover your directories or files:

  1. Click the nwrecover icon to open the NetWorker Recover window.

  2. Change servers, if necessary, by clicking the Change Server speedbar button.  If applicable, change clients by choosing Client from the Change menu.

  3. Use the mouse to highlight the icons for files or directories you want to recover, then click the Mark speedbar button.

  4. Choose Volumes from the View menu to see if the backup volumes are immediately available for your recover.

  5. Click the Start speedbar button to begin the recover.

  6. Click the Ok button in the Conflict Resolution dialog box.

  7. Click the Cancel button to close the Recover Status dialog box after the recover completion time message appears.

Summary of Backup and Recover

To use NetWorker successfully, you must be able to perform the following tasks:

  • back up files

  • monitor the backup status

  • view the backup volumes needed for a recover

  • recover files

  • relocate or rename files during a recover

  • monitor the recover status

For information about configuring the NetWorker server, refer to the IRIX NetWorker Administrator`s Guide or ask your system administrator.

The next chapter, “Archiving and Retrieving Files,” explains how to use the optional Archive Application.

IRIX NetWorker User's Guide
(document number: 007-2304-003 / published: 1997-01-11)    table of contents  |  additional info  |  download

    Front Matter
    About This Guide
    Chapter 1. Introduction to IRIX NetWorker
    Chapter 2. Getting Started
    Chapter 3. Browsing Filesystems
    Chapter 4. Backing Up and Recovering Files
    Chapter 5. Archiving and Retrieving Files
    Appendix A. Error Messages
    Appendix B. NetWorker UNIX Shell Commands
    Glossary
    Index


home/search | what's new | help